下载金陀螺炒股软件
了解金陀螺炒股软件
您所在的位置:聚富财经 > 指标公式|通达信指标公式 > 正文
  • 测个股
  • 查资金
  • 查主力
  • 通达信CCI背离主图指标公式源码(附图)

通达信CCI背离主图指标公式源码(附图)

通达信CCI背离主图指标公式股票软件源码如下:

TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,33))/(0.015*AVEDEV(TYP,33));
MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10)COLORFF8800,LINETHICK2;
MA60:=MA(CLOSE,60);
A1:=(C+O)/2;
DIF1:=EMA(CLOSE,12)-EMA(CLOSE,44);
MACD1:=EMA(DIF1,8) ;
DDIF1:=DIF1-MACD1 ;
AA:=(C+O)/2;
RSV:=(CLOSE-LLV(LOW,44))/(HHV(HIGH,44)-LLV(LOW,44))*100;
K:=SMA(RSV,7,1),COLOR0099FF,LINETHICK2;
D:=SMA(K,5,1)COLORFF00FF,LINETHICK2;
RSV1:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
K1:=SMA(RSV1,4,1),COLORWHITE,LINETHICK2;
{www.gupang.com 股旁网_通达信股票指标公式}
D1:=SMA(K1,3,1)COLORGREEN,LINETHICK2;
BU:=UPNDAY(DDIF1,3) AND DDIF1<0;
日:=150;昨前:=3;
高1:=REF(HHV(H,日),昨前);
低1:=REF(LLV(L,日),昨前);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
顶:REFDATE(高1,DATE),COLORRED;
一0.809:REFDATE(H1,DATE),COLORYELLOW;
二0.618:REFDATE(H2,DATE),COLORMAGENTA;
三0.500:REFDATE(H3,DATE),COLORWHITE;
四0.382:REFDATE(H4,DATE),COLORGREEN;
五0.191:REFDATE(H5,DATE),COLORYELLOW;
低:REFDATE(低1,DATE),COLORRED;
BB:=(二0.618+三0.500)/2;
STICKLINE( MA5>REF(MA5,1) AND K1>REF(K1,1),LOW,HIGH,0.0,0),COLORRED;
STICKLINE(MA5>REF(MA5,1) AND K1>REF(K1,1),CLOSE,OPEN,2,0),COLORRED;
白53:= CCI>=REF(CCI,1) AND MA5 <REF(MA5,1) AND CCI<-100;
STICKLINE( CCI>-100 AND K <REF(K,1),LOW,HIGH,0.0,1),COLORGREEN;
STICKLINE( CCI>-100 AND K <REF(K,1),CLOSE,OPEN,2,1),COLORGREEN;
STICKLINE( CCI<-100 AND CCI>-149 AND K <REF(K,1),LOW,HIGH,0.0,0),COLORGREEN;
STICKLINE( CCI<-100 AND CCI>-149 AND K <REF(K,1),CLOSE,OPEN,2,0),COLORGREEN;
STICKLINE(CCI<-150,LOW,HIGH,0.0,0),COLORWHITE;
STICKLINE( CCI<-150,CLOSE,OPEN,2,0),COLORWHITE;
DRAWTEXT(白53,C *0.98,' B'),COLORFFFF00;
STICKLINE(DDIF1>REF(DDIF1,1) AND DDIF1<0,LOW,HIGH,0.0,0),COLOR0099FF;
STICKLINE(DDIF1>REF(DDIF1,1) AND DDIF1<0,CLOSE,OPEN,2,0),COLOR0099FF;
 

通达信CCI背离主图指标公式

(责任编辑:谈股论金)
更多
序号 股票名称 提示日期 累计涨幅 问股
2012-06-20 10.97% 咨询
2012-06-14 13.53% 咨询
2012-06-12 14.37% 咨询
2012-06-08 15.78% 咨询
2012-06-06 17.11% 咨询
2012-06-05 17.98% 咨询
2012-06-05 26.36% 咨询